FORUM

SX1302CSS915GW1 SPI errors

Hello,

I recently bought a SX1302CSS915GW1 dev kit to start dabbling in Lora.

I’ve been following through the user guide and everything was going well. However, when I run some of the apps (such as “chip_id”), it will only work in USB and not SPI mode?

Running “./chip_id -d /dev/spidev0.0” returns the following:
CoreCell reset through GPIO4…
SX1261 reset through GPIO4…
CoreCell power enable through GPIO1…
CoreCell ADC reset through GPIO13…
Opening SPI communication interface
Note: chip version is 0x00 (v0.0)
ERROR: Failed to set SX1250_0 in STANDBY_RC mode
ERROR: failed to setup radio 0
ERROR: failed to start the gateway

I’ve ensured SPI & I2C are enabled on the PI board using the “raspi-config” utility. Running the USB version of chip_id works fine.

As you can see above, I’ve also updated pin assignments in the “reset_lgw.sh” script to match what the PI header pins appear to be in the dev board schematic. But nothing has changed.

The “test_loragw_com_sx1250” & “test_loragw_com_sx1261” test cases also fail after the first cycle. Again, running these test apps using USB works fine.

What am I missing here?

I’m actually getting the same error when running the “./test_loragw_hal_tx –u –d /dev/ttyACM0 -k0 -c0 -r1250 -f868.1 -mLORA --pa 1 -l12 --pwid 14 -s7 -b125 -z16 -n10000 -t 100” command to test the HAL TX. And this is supposed to be USB based command??