SX1272 and SX1262 lora sync word compatibility

I am trying to use a SX1262 based device on a private network which will be received on a SX1272 based device (Legacy device already in the field).

I cannot get the SX1272 to receive from the SX1262 and i think it may be related to the 16 bit sync word on the 1262?

Are the two devices compatible, and if they are, any suggestions on setting the sync words?


The SX126X and SX127X are compatible, but stick to the standard public and private syncwords. The exception is that SF6 is not compatible between SX127X and SX126X.

SX127X publc,0x34 private,0x12
SX126X publc,0x3444 private,0x1424

Veer away from those syncwords and you can introduce compatibility issues.

Hi Stuart,

Thanks for your reply.

The problem I have is that I can’t seem to receive data on a SX1272 which has been transmitted from a SX1262.

The sync word on the 1272 is set to 34 and I have tried 34 on the 1262 but as the 1262 uses a 16 bit sync word and 1272 uses an 8 bit?

Could that be the issue?


As mentioned before the public syncword for SX126x is 0x3444 and NOT 0x34

Sorry. I think i am being a bit slow here.

I am not using the devices in a full LOWAN network.

In my system i don’t have a gateway. I use a SX1272 as a gateway (master receiver) and the Sync word is set to 34. I then transmit to the SX1272 with other SX1272 devices. All works fine.

When i try and send data from an SX1262 to a SX1272 i don’t receive anything. I have tried sending data from the 1262 with the sync word set to 0x3400 and 0x0034 but whichever i use I cant receive it.

My question really is can a SX1272 set in Lora mode have 2 way communication with a SX1262 setup in Lora mode?


Syncwords have nothing to do with gateways.

So what happens when you use the correct syncword for SX126X which as previously stated is 0x3444 ?

It is not seen by my receiver which is a SX1272.

Basically, I am trying to send data from a SX1262 and receive the data on a SX1272.

No idea then, if the LoRa settings match it should work.

The library for the SX1272 will need to support that device since the way they are configured is different to the SX1278 for instance.

I beat my head against this two years ago.

SX1272 sync word 0x12/0x34 works with the SX1262 sync words 0x1424/0x3444

You can use others with the SX1272 and they ‘work’ but are not compatible with the SX1262 or LLCC68.

Far as I can tell the SX1211/SX1272/SX1262/LLCC68 are compatible in fsk mode.

Also some of the spreading modes on the SX1272/SX1262 aren’t supported by the LLCC68. With SF10 the LLCC68 will transmit what I think is the preamble but then stops.

Thanks. I appreciate the advice

Here is an extract from the LLCC68 datasheet describing the different configuration supported by the chip:

If an unsupported configuration is requested (SF10 with BW125 for instance), the SetModulationParams command will return an error.

Do you confirm that in private LORA network a SX1272 with syncword 0x12 can communicate with a SX1261 or LLCC68 with syncword 0x1424?
(with appropriated SF and BW of course).
Best regards

The SX126x/LLCC68 datasheet specifies a 16-bit long value because the meaningful data is 8-bit long (as for SX127x family) but divided in two 4-bit long fields spread over a 16-bit register. A reference implementation is available in the driver (see

To summarize, the 0x1424 value from the SX126x/LLCC68 datasheet is equivalent to the 0x12 value from the SX127x datasheet - same applies to the public network syncword.