How to enable Low Data Rate Optimization when using SF7-10 on SX1301


Very thankful to open this topic.
As described in the title, I try to enable Low Date Rate Optimization when SX1301 uses SF7-10.
I very much appreciate it if anyone can tell me which registers should be modified and the value’s meaning.
And I know the register’s description of SX1301 is not provided. But I think the address and value of registers are enough for my application.
Thanks again.

Here is some useful information.
Controller: Raspberry Pi 3B+
HAL library:

Issues have been fixed!!

I have found a DS from ancient times about SX1301. There are two REGs about LDO. But the name has changed to PPM. So, I tried all values to check if LDO was enabled. Finally, SET PPM_OFFSET to 0x7F and SET MBWSSF_PPM_OFFSET to True are worked for me.
So, I think this topic should be closed. Thanks to all reviewers and the platform. :grinning: :smiley:

Another thing is some programs modify and register values in unknown places. GOOD STACK!!