FORUM

Cannot connect TTN server

Hi , i am trying to connect my gateway to TTN. I created necessery files(cups.key lns.key reset_lgw.sh rinit.sh station station.conf tc.trust tc.uri) maybe it was be incomplete.

i created .key files and .trust file by ttn guide.

my station.conf file is this way
station.conf
{
/* If slave-X.conf present this acts as default settings /
“SX1301_conf”: { /
Actual channel plan is controlled by server /
“lorawan_public”: true, /
is default /
“clksrc”: 1, /
radio_1 provides clock to concentrator /
/
path to the SPI device, un-comment if not specified on the command line e.g., RADIODEV=/dev/spidev0.0 /
“device”: “/dev/spidev0.1”,
/
freq/enable provided by LNS - only HW specific settings listed here /
“radio_0”: {
“type”: “SX1257”,
“rssi_offset”: -166.0,
“tx_enable”: true,
“antenna_gain”: 0
}
},
“station_conf”: {
“log_file”: “stderr”, /
“station.log” /
“log_level”: “DEBUG”, /
XDEBUG,DEBUG,VERBOSE,INFO,NOTICE,WARNING,ERROR,CRITICAL /
“log_size”: 10000000,
“log_rotate”: 3,
“CUPS_RESYNC_INTV”: “1s”,
/
“device”: “/dev/spidev0.1”,*/
“radio_init”: “rinit.sh”,
“RADIO_INIT_WAIT”: “2s”,
“RX_POLL_INTV”: “10ms”,
“TC_TIMEOUT”: “360s”
}
}
tc.uri file contains wss://eu1.cloud.thethings.network:443

I coppied all files to my device and i run .station and i faced screen below
basic

How could i fix this and connect my gateway to TTN server ?

You might get a answer in here, eventually.

Or maybe ask the question in the actual TTN forums.

Hi @oguzhan.esin,

Please don’t open a new forum topic or github issue for every new question that you have. Let’s keep it confined to a single thread.

As described in the GH issue, HTTP status code 403 means your gateway is not authorized to establish a connection to TTN. Please check your authentication credentials. This error is unrelated to UDP packet forwarder because the UDP packet forwarder does not offer any authentication.

For reference, here are the other posts related to your endeavour to get station working on a mips openwrt platform:

https://github.com/lorabasics/basicstation/issues/153
https://github.com/lorabasics/basicstation/issues/151
https://github.com/lorabasics/basicstation/issues/150
https://github.com/lorabasics/basicstation/issues/149
https://forum.lora-developers.semtech.com/t/how-to-use-lora-basicstation-instead-of-udp-packet-forwarder/862/3
https://forum.lora-developers.semtech.com/t/building-and-implementation-lora-basicstation-on-mips-architecture/834/9

Hi @abeitler i am here again,

I have another issue using basicstation

And i see datas below on live data section on ttn server simultaneously.

10:22:09 Disconnect gateway

10:22:09 Receive gateway status

10:22:09 Connect gateway

10:21:57 Disconnect gateway

Hi @oguzhan.esin,

I’m glad you sorted out the authentication problem.

Now, station receives the router_config message from the LNS and tries to start the radio with the given configuration. However, the HAL reports that no connection to the radio board can be established. This points to a wiring issue between your host platform and the radio board. Please also check that the sx1301 chip is in the correct reset state. For verifying proper connectivity between the host and the radio board please use the corresponding tools in the HAL repo.

1 Like

Hi @abeitler, i already tried this test modules and also i have problem. I wonder that if i have a connection problem, how pkt_forwarder works on it successfully. I could not figure out.

test_loragw_spi module:

@abeitler hi , i have one shot question for you.

How could i modify libloragw library before basicstation scripts pull them ?

I need to modify libloragw library for my own hardware then it will works properly i guess.